Unieke waarden invoeren

Als je informatie in een werkblad moet invoeren, kan het voorkomen dat die invoer een unieke waarde moet zijn. Het beste voorbeeld is wellicht het invoeren van een factuurnummer. Dat nummer moet uniek zijn. In Excel kun je Gegevens Validatie gebruiken om af te dwingen dat een gebruiker nooit twee keer hetzelfde factuurnummer kan invoeren. Dat is wel zo prettig, maar hoe werkt dat?

  • Selecteer het bereik waar de factuurnummers moeten worden ingevoerd. Bijvoorbeeld B6:B10
  • Klik op het tabblad Gegevensen kies: Gegevensvalidatie > Gegevensvalidatie…
  • Klik op het tabbladInstellingenvan de dialoog Gegevensvalidatie
  • Kies, bij Toestaan: voor Aangepast
  • Voer de volgende formule in bij Formule: =AANTAL.ALS($B$6:$B$10;B6)<2
  • Vul, eventueel, ook de tabbladen Invoerbericht en Foutmelding in
  • Klik OK

Wanneer je nu in een van de cellen in B6:B10 een factuurnummer invoert dat al bestaat, zal Excel dat niet toestaan en je daarover informeren!

Download werkboek